Download

Notes:

  • Using Lite Installer will be at your own risk. You must use the latest data.grf, rdata.grf and BGM folder from the latest kRO.
  • It is recommended to download Full Installer to prevent issues.
  • Using our APK requires Android Version 5.0 or Higher
  • If you have any issues regarding download, kindly post your issue on our forum.